Creating Topics

Create a Topic

Each topic type enables you to insert specific elements.
  1. In the content library, navigate to a folder and click Create New.
  2. Select the topic type you want to create.
  3. Enter a title and file name.
  4. Optional: Create the file in a folder different from the current folder by clicking Change and selecting a new location.
  5. Optional: Assign the file to collections by clicking Collections and selecting collections from the list.
  6. Optional: Assign metadata to the file by filling in the Metadata fields.
  7. Do one of the following:
    • To create and open the file, click Create & Edit.
    • To create the file and return to the content library, click Create.

Topic Elements

The Content Editor enables you to view topic elements in different tag modes.

Tip: In the Content Editor, you can switch between different tag modes by clicking the gear icon and using the Tags drop-down menu.

For detailed information on the DITA attributes, see DITA 1.3 Specification.

Table 1. Tags Menu Options
OptionDescriptionExample
Full Tags With AttributesDisplays the entire DITA element syntax including any attributes. example of Full Tags With Attributes mode
Full TagsDisplays only the DITA element name.example of Full Tags mode
Short TagsDisplays a blue tag indicator wherever a DITA element occurs.example of Short Tags mode
No TagsTurns off all tags in the Content Editor

Insert an Element to a Topic

You use the quick insert menu to insert elements into your content.

  1. In the content library, hover over a topic and click Open.
  2. Place your cursor where you want to insert an element.
  3. Open the quick insert menu by doing one of the following:
    • Press Ctrl > Enter (Windows) or Cmd > Enter (Mac).
    • Click the plus icon.
  4. In the quick insert menu, type an element name or scroll through the list of available elements.
    For detailed information on the DITA elements, see Oasis: Element quick reference.
  5. Insert an element by doing one of the following:
    Tip: The elements that display in the quick insert menu are context-sensitive and the arrows indicate if the element will be a parent, sibling, or child of the element in which you have your cursor. To change the element suggestion mode, use the Insert drop-down menu and select Before , After or Intelligently.
    • Click the element.
    • By pressing the Up arrow and Down arrow keys, highlight the element and press Enter.
    • Drag and drop the element.

Copy and Paste an Element in a Topic

You can copy and paste elements it in the same topic or different topics by using the footer or tags.

  1. In the content library, hover over a topic and click Open.
  2. To copy an element by using the footer, do the following:
    1. Place your cursor in the element that you want to copy.
    2. In the footer, click the element that you want to copy.
      Figure 1. Element Context Menu
    3. From the context menu, select Copy.
  3. To copy an element by using the Tags context menu, right-click a tag and select Copy.
    Figure 2. Tag Context Menu
  4. In the same topic or a different topic, right-click where you want to paste the element and click Paste.

Move Elements in a Topic

You can reorder elements in topics by using the footer or by dragging and dropping tags.

  1. In the content library, hover over a topic and click Open.
  2. To move an element by using the footer, do the following:
    1. Place your cursor in the element that you want to move.
    2. In the footer, click the element that you want to move.
      Figure 3. Element Context Menu
    3. From the context menu, select Move Up or Move Down.
      Tip: The Move Up and Move Down options display if the element can be moved to a valid position.
  3. To move an element by using the Tags context menu, drag and drop a tag to a new position.
    Tip: You can drag and drop tags between different Content Editor.

    In the following example, the ul tag is being dragged and dropped from one browser window to another browser window.

Wrap an Element in a Topic

You can wrap elements in other elements by using the footer or tags.

  1. In the content library, hover over a topic and click Open.
  2. To wrap an element by using the footer, do the following
    1. Place your cursor in the element that you want to wrap in another element.
    2. In the footer, click the element that you want to wrap.
      Figure 4. Element Context Menu
    3. From the context menu, select Wrap Element.
  3. To wrap an element by using the Tags context menu, right-click a tag and select Wrap Element.
    Figure 5. Tag Context Menu
  4. In the quick insert menu, do the following:
    Figure 6. Quick Insert Menu
    1. Type an element name or scroll through the list of available elements.
    2. Insert the element by pressing Enter or by clicking the element.

Unwrap an Element in a Topic

You can unwrap elements by using the footer or tags.

  1. In the content library, hover over a topic and click Open.
  2. To wrap an element by using the footer, do the following
    1. Place your cursor in the element that you want to unwrap.
    2. In the footer, click the element that you want to unwrap.
      Figure 7. Element Context Menu
    3. From the context menu, select Unwrap Element.
  3. To unwrap an element by using the Tags context menu, right-click a tag and select Unwrap Element.
    Figure 8. Tag Context Menu

Replace an Element in a Topic

You can replace elements with other elements by using the footer or tags.

  1. In the content library, hover over a topic and click Open.
  2. To replace an element by using the footer, do the following
    1. Place your cursor in the element that you want to replace.
    2. In the footer, click the element that you want to replace.
      Figure 9. Element Context Menu
    3. From the context menu, select Replace Element.
  3. To replace an element by using the Tags context menu, right-click a tag and select Replace Element.
    Figure 10. Tag Context Menu
  4. In the quick insert menu do the following:
    Figure 11. Quick Insert Menu
    1. Type an element name or scroll through the list of available elements.
    2. Insert the element by pressing Enter or by clicking the element.

Remove an Element from a Topic

You can remove elements from a topic by using the footer or tags.

Important: Removing an element deletes the element contents and its child elements.
  1. In the content library, hover over a topic and click Open.
  2. Place your cursor in the element that you want to remove.
  3. To remove an element by using the footer, do the following:
    1. In the footer, click the element that you want to remove.
      Figure 12. Element Context Menu
      Tip: Hovering over an element in the footer highlights its location in the topic.
    2. Click Remove.
  4. To remove an element by using the Tags context menu, right-click a tag and select Remove.
    Figure 13. Tag Context Menu

Images

Heretto CCMS enables you to add common format images to your topics. You can also add callouts, or annotations, to your images without leaving the Content Editor.

Annotations

Adding annotations to an image places the image element in an svg-container element, which allows you to add annotations over the image without modifying the image itself. This enables you to reuse the original, non-annotated image elsewhere.

Figure 14. SVG Container

You can add annotations to any image that is supported by Heretto CCMS.

Figure 15. Image Context Menu
Figure 16. Annotations Interface

The Annotations interface enables you to:

  • Drag and drop the following elements from the Topic Preview pane on the right into the Image Preview pane on the left.
    • Ordered list items
    • Steps
    Note: The callouts that you annotate images with update automatically as you add, move, or remove the ordered list item elements or step elements.
  • Move and rotate callouts in the Image Preview pane.
  • Edit the DITA content in the Topic Preview pane.
  • Switch between different images by using the image context menu in the Topic Preview pane.

Insert an Image

Add images to illustrate concepts and ideas. You can also set image attributes and properties, such as width.
  1. In the content library, hover over a topic and click Open.
  2. Place your cursor where you want to insert an image.
  3. In the toolbar, click the Image icon.
  4. In the Select Media window, do one of the following:
    OptionDescription
    To insert an existing image, navigate to the image, select the image, and click Select.
    To upload and insert a new image,do the following:
    1. Click the Upload icon.
    2. Click Select files to upload.
    3. Select the files that you want to upload.
    4. Click Upload.
    5. Select the image and click Select.
  • To align the image, change the image width, or add alternate text, select the image and use the context menu.
  • To annotate the image, see Annotate an Image.

Change an Image

You can change an image added to a topic by using the image context menu.

  1. In the content library, hover over a topic and click Open.
  2. Select an image and in the context menu, click Change.
  3. In the Select File window, navigate to and select a new image.
  4. Click Select.

Remove an Image

You can remove an image added to a topic by using the image context menu.

  1. In the content library, hover over a topic and click Open.
  2. Select an image and in the context menu, click Remove.

Annotate an Image

You can add callouts to images without modifying the images themselves. It is useful if you want to reuse the same image in different topics.
  1. In the content library, hover over a topic and click Open.
  2. Insert an annotation by doing the following:
    1. Click the image element that you want to annotate and from the Image Context menu, select Annotate Image.
      Figure 17. Image Context Menu
      The Annotations interface opens.
    2. From the Topic Preview pane on the right, drag and drop ordered list item elements or step elements into the Image Preview pane on the left.
      Note: The callouts that you annotate images with update automatically as you add, move, or remove the ordered list item elements or step elements.
  3. Optional: Edit an annotation by doing any of the following:
    OptionDescription
    To rotate the annotation,do the following:
    1. Select the annotation.
    2. Click and hold .
    3. Move your mouse.
    To combine multiple graphical elements,do the following:
    1. Press and hold Shift.
    2. Click the elements that you want to combine.
    3. Right-click any selected element.
    4. Select group.
    To move a graphical element,do the following:
    1. Click and hold the graphical element.
    2. Move your mouse.
  4. Optional: In the Image Preview pane on the left, remove an annotation by right-clicking the annotation and selecting Delete from the context menu.
  5. Do one of the following:
    • To save your progress and keep the Annotations interface open, click Save.
    • To save your progress and return to the Content Editor, click Save & Close.
    • To discard your progress, click Cancel.
In the Content Editor, you can edit annotated images at any point by clicking the image element and selecting Edit Annotation from the context menu.

Insert an Image Map

You can define linkable areas over an image by using image map elements.

  1. In the content library, hover over a topic and click Open.
  2. Insert an image map element. For more information, see Insert an Element to a Topic.
  3. In the Select File window, choose an image and click Select.
    The image map element is inserted. When you click the image, the Image Map context menu appears.
    Empty Image Map
  4. In the Topic toolbar, click the source editor icon.
    Figure 18. Topic Toolbar
    Topic Toolbar
  5. Inside the <imagemap> element, specify the linkable areas shape, coordinates, and target links.
    <imagemap id="imagemap_sjn_dql_1qb"><image href="Lightning_Toaster.jpg" id="image_tjn_dql_1qb"/>
                    <area><shape>circle</shape><coords>290, 340, 40</coords><xref format="dita" href="knob_reference.dita"/></area></imagemap>
  6. Click Save & Close.
You can click the image to see the defined linkable areas.
Filled-in Image Map

Videos

Heretto CCMS enables you to insert videos into topics. We recommend inserting videos from external services like YouTube or Vimeo.

Note: You can also insert a video from the content library. However, we strongly recommend to use an external video hosting service instead.

Examples

Figure 19. YouTube Video

Insert an External Video

You can insert a video to a topic by using the Insert Video icon in the Content Editor toolbar.

Note: This procedure shows you how to insert a YouTube or Vimeo video into a topic. However, you can insert a video form a different service in an analogous way.
Obtain a video link by doing any of the following:
  1. To obtain a link to a YouTube video, do the following:
    1. Go to the YouTube video that you want to add to a topic.
    2. Below the video, click Share and select Embed
    3. Optional: In the window that appears, adjust any additional options like the starting point of your video, player appearance, etc.
    4. Copy the video embed link.
  2. To obtain a link to a Vimeo video, do the following:
    1. Go to the Vimeo video that you want to add to a topic.
    2. Below the video, click Share.
    3. Copy the video embed link.
Reference the video in a topic by doing the following:
  1. In the content library, hover over a topic and click Open.
  2. Place your cursor where you want to insert a video.
  3. In the toolbar, click the Insert Video icon.
  4. In the dialog, do the following:
    1. From the Link To drop-down menu, select A URL (External link).
    2. In the Link (href) field paste the link to the video that you obtained in 1 or 2.
    3. Click Apply.
  5. Optional: Set the video attributes by selecting the video and clicking the Attributes tab.
    Tip: You can control the size of the video player in the output by setting the width attribute and the height attribute.

Insert a Video from the Content Library

You can insert a video to a topic by using the Insert Video icon in the Content Editor toolbar.

Important: If possible, we strongly recommend to insert a video from an external video hosting service. See Insert an External Video.
Upload a video to the content library. See Upload Files to the Content Library.
Note: Heretto CCMS supports common video formats, including: MOV, AVI, and MP4.
  1. In the content library, hover over a topic and click Open.
  2. Place your cursor where you want to insert a video.
  3. In the toolbar, click the Insert Video icon.
  4. In the linking dialog, do the following:
    1. From the Link To drop-down menu, select A File in Heretto.
    2. Near the Href field, click Select File.
    3. Select the video that you want to insert and click Link to File.
  5. Optional: Set the video attributes by selecting the video and clicking the Attributes tab.
    Tip: You can control the size of the video player in the output by setting the width attribute and the height attribute.

Insert an Ordered or Unordered List

Insert a list to organize your content.

  1. In the content library, hover over a topic and click Open.
  2. In the toolbar, click the unordered list or ordered list icon.
    Tip: You can also use the quick insert menu to add an unordered list element or ordered list element. For more information, see Insert an Element to a Topic.
  3. To insert another list item, press Enter.
  4. To indent the current list item, press Tab.

Insert a Definition List

Definition lists are useful if you want to explain different terms in the main flow of a document.

  1. In the content library, hover over a topic and click Open.
  2. Place your cursor where you want to insert the definition list element.
  3. Open the quick insert menu by doing one of the following:
    • Press Ctrl > Enter (Windows) or Cmd > Enter (Mac).
    • Click the plus icon.
  4. In the quick insert menu, enter dl or definition list
  5. Select Definition List.
Manage the definition list. See Manage a Definition List.

Manage a Definition List

Heretto CCMS enables you to easily add, remove, and alphabetize definition list entries.

Insert a definition list element. See Insert a Definition List.
  1. In the Content Editor, click a definition list.
  2. In the dialog, do any of the following:
    • To add a new entry, click Insert List Entry.
    • To remove an entry, click the entry and click Remove List Entry.
    • To alphabetize definition terms in the list, click Alphabetize.

Tables

Use the Table menu to create a table and determine the properties of the table.

Tip: The publishing engine can handle table formatting parameters such as row heights, column widths, and border styling in the output format.

Insert a Table

Insert a table to organize information in a grid.

  1. In the content library, hover over a topic and click Open.
  2. Place your cursor where you want to insert a table.
  3. In the toolbar, click the table icon.
  4. Set the table parameters.
  5. Click Save.

Merge Table Cells

Create tables with cells that span several columns or rows.

  1. In the content library, hover over a topic and click Open.
  2. Place your cursor in the cell you want to merge.
  3. From the context menu, next to Join, select Left , Right, Up, or Down.

Split Table Cells

Reconfigure a table by splitting joined cells.

  1. In the content library, hover over a topic and click Open.
  2. Place your cursor in the joined cell that you want to split.
  3. From the context menu, next to Split, select Horizontal or Vertical.

Add Table Row Headers

Use the Attributes tab to add row headers to a table.

  1. In the content library, hover over a topic and click Open.
  2. Place your cursor in the table element.
  3. On the right, click Attributes.
    Tip: The attributes that show in the Attributes tab are context-sensitive. To ensure that you are applying attributes to the correct element, you can check the element drop-down menu at the top of the Attributes tab.
  4. In the Attributes tab, in the rowheader drop-down menu, select firstcol.
  5. Add the row header text in row headers.

Footnotes

Footnotes supplement content with references to additional information and are typically placed below the main body of the document.

Numerical Annotations

Remember: We recommend using numerical annotations with textual content.

By default, footnotes are indicated by numerical annotations. Heretto CCMS automatically manages their order. For example, if you insert a new footnote between existing footnotes, their order updates accordingly to their position in the topic.

Figure 20. Two Numerical Annotations.

In the following example, footnote “1” corresponds to “Paragraph A” and footnote “2” corresponds to “Paragraph C”. An additional footnote is added to “Paragraph B” in Three Numerical Annotations.

Figure 21. Three Numerical Annotations.

In the following example, a footnote is added to “Paragraph B”. The order of the numerical footnotes updates automatically.

Symbolic Annotations

Remember: We recommend using symbolic annotations with numerical content.

You insert symbolic annotations by modifying the callout attribute value of a footnote. Symbolic annotations do not update automatically. For example, if you insert a new footnote between existing symbolic footnotes, you need to update their annotations manually.

Multiple Annotations

You can annotate multiple items in a topic with a single footnote.

Figure 22. Multiple Footnote Annotations.

In the following example, multiple “Footnote A” annotations are inserted in “Paragraph A”, “Paragraph B”, and “Paragraph C”.

Output

Depending on the output, footnotes can render differently. For example, in some outputs, footnotes may be rendered as endnotes. You can change the way footnotes render by modifying publishing scenarios.

Figure 23. Footnotes in the PDF Output.

In the following example, footnote annotations render as non-clickable superscripts.

Figure 24. Footnotes in the HTML5 Output.

In the following example, footnote annotations render as links. You can click an annotation to jump between the footnote callout and the corresponding footnote content.

Insert Footnotes

Supplement content with references that are placed outside the main body of the document.

  1. In the content library, hover over a topic and click Open.
  2. Insert a footnote element.
    For more information, see Insert an Element to a Topic.
    Figure 25. Empty Footnote
  3. In the Footnotes section, fill in the Footnote content.
    Figure 26. Filled in Footnote
  4. If needed, add more footnotes by repeating 2 through 3.
    Figure 27. Multiple Footnotes

Do any of the following:

Modify Footnote Annotations

Modify the footnote annotation type by editing the callout attribute value of a footnote element.

Insert a footnote element to a topic. See Insert Footnotes.
Important: We recommend using numerical annotations with textual content and symbolic annotations with numerical content. Footnotes with modified annotations do not update automatically as you add new footnotes.
  1. Select a footnote by doing any of the following:
    • Place your cursor directly after the footnote annotation.
    • At the bottom of the topic, in the Footnotes section, place your cursor anywhere in the Footnote content.
  2. On the right, open the Attributes tab by clicking Attributes.
  3. In the Attributes tab, in the callout field, enter a custom annotation for the footnote.
    Enter *

Insert Multiple Footnote Annotations

A single footnote can use several annotations. You insert multiple footnote annotations by creating cross-references to a footnote element.
Insert a footnote element to a topic. See Insert Footnotes.
  1. Place your cursor where you want to add a footnote annotation.
  2. In the toolbar, click the Insert Link icon.
  3. In the Link dialog, from the Link To drop-down menu, select An Element in this file (Local link).
  4. Click Select Element.
  5. Select the footnote element that you want to link to by doing the following:
    1. In the Create/Edit Link dialog, select the element.
      Figure 28. Selected footnote Element
    2. From the list that appears, select the element.
    3. If prompted about the element ID, click OK and Save.
      Tip: Heretto CCMS generates ID values automatically but you can enter your own values. The ID values must be unique. Assigning customized values may boost consistency in your documentation.
    4. Click the Insert Content button.
    Important: A footnote element with the ID attribute is neither visible in the Content Editor nor in the output.
  6. If needed, repeat 1 through 5.
You inserted multiple annotations to a single footnote.
Figure 29. Multiple Footnote Annotations.

In the following example, multiple “Footnote A” annotations are inserted in “Paragraph A”, “Paragraph B”, and “Paragraph C”.

Remove Footnotes

Remove unwanted footnotes.

  1. In the content library, hover over a topic and click Open.
  2. At the bottom of the topic, in the Footnotes section, place your cursor in the Footnote that you want to remove.
  3. Remove the Footnote content.
    An empty Footnote placeholder appears.
    Figure 30. Empty Footnote Placeholder
  4. Remove the empty Footnote placeholder by pressing Backspace.
You removed the footnote content and footnote annotation.

Insert an Equation

You add an equation to your topic by inserting a mathml element.

  1. In the content library, hover over a topic and click Open.
  2. In the toolbar, click the equation icon.
  3. Edit the equation by doing the following:
    1. Click the equation and select Edit.
      Figure 31. Equation Context Menu
    2. In the equation editor, edit the equation.
      Figure 32. Equation Editor
      Tip: You can handwrite the equation by clicking .
      Figure 33. Handwriting in the Equation Editor.

      You can get back to the main equation editor interface at any time by clicking .

    3. In the equation editor, click Save.
Figure 34. Inserted Equation.
Tip: You can edit or remove an equation at any time by clicking the equation and using the context menu.

Edit an Equation

You can quickly edit equations that need to be updated.

  1. In the content library, hover over a topic and click Open.
  2. Click the equation and from the context menu select Edit.
    Figure 35. Equation Element Context Menu

Remove an Equation

You can quickly remove equations that you no longer need from your topics.

  1. In the content library, hover over a topic and click Open.
  2. Click the equation and from the context menu select Remove.
    Figure 36. Equation Element Context Menu

Insert Special Characters

Add special characters from the Symbol menu to your topic.

  1. In the content library, hover over a topic and click Open.
  2. Place your cursor where you want to insert a symbol.
  3. Click the Symbol menu and select the symbol you want to insert.

Insert a Non-Breaking Space

Heretto CCMS enables you to see non-breaking space characters.

  1. In the content library, hover over a topic and click Open.
  2. Press Ctrl > Shift > Space (Windows) or Cmd > Shift > Space (macOS).
The non-breaking spaces are indicated in the following way:
Figure 37. Non-Breaking Spaces in the Content Editor.
Figure 38. Non-Breaking Spaces in the Source Editor
Product&#160;Name

XML Comments

Heretto CCMS enables you to add XML comments in the DITA source that show in the Content Editor.

XML Tip Comment Example

<concept id="concept-7143" xml:lang="en-us">
    <title>Concept A</title>
    <shortdesc>Short description.</shortdesc>
    <prolog>
        <author translate="no" type="creator">User Name &lt;user.name@organization.com&gt;</author>
    </prolog>
    <conbody>
        <section>
            <title>Section A</title>
            <p>Paragraph A</p>
            <p>Paragraph B</p>
            <!-- TIP: Lorem ipsum dolor sit amet, consectetur adipiscing elit. -->
            <p>Paragraph C</p>
        </section>
    </conbody>
</concept>

Add an XML Tooltip Comment

You add an XML comment by modifying the DITA source code.

  1. In the content library, hover over a topic and click Open.
  2. In the topic toolbar, click the edit source icon.
  3. In the source editor pane, add a comment in the following way <!-- comment -->
    Where comment is the content of your comment.
    <concept id="concept-4201" xml:lang="en-us">
        <title>Concept A</title>
        <shortdesc>Short Description</shortdesc>
        <conbody>
            <note>
                <p>A note.</p><!--TIP: A tooltip comment.-->
            </note>
        </conbody>
    </concept>
  4. Click Save & Close.

Check Spelling

You can check the spelling of your topics.

  1. In the content library, hover over a topic and click Open.
  2. If the spell check is disabled, click the spell check icon.
  3. Replace a misspelled word by right-clicking the word and selecting a word from the Did you mean list.

Add Words to the Dictionary

Add words to the dictionary so that spell check recognizes the correct spelling.

Remember: The dictionary applies to all users in the organization. When you add a word to the dictionary, it applies to all users in the organization.
  1. In the content library, hover over a topic and click Open.
  2. If the spell check is disabled, click the spell check icon.
  3. Right-click a misspelled word and select Add To Dictionary.

Topic Element Attributes

Assigning attributes enables you to manage the properties of elements in a topic.

For detailed information on the DITA attributes, see DITA 1.3 Specification.

Edit Topic Element Attributes

You edit the attributes of an element in a topic to manage its properties.

  1. In the content library, hover over a topic and click Open.
  2. In the Content Editor, on the right, click Attributes.
  3. In the Content Editor, place your cursor in the element that you want to edit the attributes for.
  4. In the Attributes tab, fill in the relevant fields.

Topic XML Code

Heretto CCMS enables you to edit the source code of your topics.

Edit the Topic XML Code

You edit the XML code in the Source Editor.

Important: If multiple users collaborate on a resource, Heretto CCMS places a collaboration lock on the topic and the XML code is not editable.
  1. In the content library, hover over a topic and click Open.
  2. In the Topic toolbar, click the source editor icon.
    Figure 39. Topic Toolbar
    The Edit Source window shows the topic XML code side-by-side with the rendered preview.
  3. Optional: Expand or collapse elements by clicking the corresponding Plus icons or Minus icons.
    Tip: Collapsing irrelevant elements increases readability and limits distractions.
  4. Edit the XML code.
    Tip: The gray line in the scroll bar indicates your cursor position.
  5. Optional: Make your code more readable by clicking the Format the source icon.
  6. Save your edits by doing any of the following:
    • To save the file and preview the changes, click Save.
    • To save the file and close the Edit Source window, click Save & Close.
  7. If the Source XML Invalid window appears, do any of the following:
    Important: The Source XML Invalid window appears if Heretto CCMS detects that something is wrong with the XML code that you edited.We recommend fixing the invalid XML files immediately because they may result in severe publishing errors. The Invalid XML code is indicated by a red underline and a red rectangle in the scroll bar.

    If you plan to fix the invalid XML code later and you don't want to lose your changes, you can save the invalid XML code. Heretto CCMS notifies you about invalid XML files by displaying the Invalid File icon in the content library.

    • To save the invalid XML code, click the OK button.
    • To edit the invalid XML code, click Cancel.

Find and Replace the Topic XML Code

You can find and replace the XML code of a topic in the Source Editor.

Important: If multiple users collaborate on a resource, Heretto CCMS places a collaboration lock on the topic and the XML code is not editable.
  1. In the content library, hover over a topic and click Open.
  2. In the Topic toolbar, click the source editor icon.
    Figure 40. Topic Toolbar
  3. Press Cmd > F (Mac) or Ctrl > F (Windows).
  4. Search for a term by doing the following:
    1. In the Find field, type in a search term and press Enter.
      Search for <metadata>
      All search results are highlighted.
    2. Optional: Restrict the search to match case by clicking the Match Case icon.
    3. Optional: Restrict the search to match whole words only by clicking the Match Whole Word icon.
    4. Optional: Enable regular expression in the search by clicking the Use Regular Expression icon.
    5. Optional: Restrict the search scope by highlighting the document area that you want to include in the search results, and click the Find in selection icon.
  5. If you want to navigate the search results, do any of the following:
    • To navigate to the next result, click the Next match icon.
    • To navigate to the previous result, click the Previous match button.
  6. If you want to replace your search results, do the following:
    1. In the Find dialog, click the Toggle Replace mode icon.
      The Find dialog dialog expands to the Find and Replace dialog.
    2. In the Replace field, type in a term that would replace the search results.
    3. To replace the selected search result, click Replace icon.
    4. To replace all search results, click Replace All icon.
  7. Save the file by doing any of the following:
    • If you edit a topic, to save the changes and leave the Edit Source window open, click Save.
    • If you edit a topic, to save the file and close the Edit Source window, click Save & Close.
    • If you edit a map, save changes by clicking Save.
  8. If the Source XML Invalid window appears, do any of the following:
    Important: The Source XML Invalid window appears if Heretto CCMS detects that something is wrong with the XML code that you edited.We recommend fixing the invalid XML files immediately because they may result in severe publishing errors. The Invalid XML code is indicated by a red underline and a red rectangle in the scroll bar.

    If you plan to fix the invalid XML code later and you don't want to lose your changes, you can save the invalid XML code. Heretto CCMS notifies you about invalid XML files by displaying the Invalid File icon in the content library.

    • To save the invalid XML code, click the OK button.
    • To edit the invalid XML code, click Cancel.